🤍 전 강의 25% 할인 중 🤍

2024년 상반기를 돌아보고 하반기에도 함께 성장해요!
인프런이 준비한 25% 할인 받으러 가기 >>

  • 카테고리

    질문 & 답변
  • 세부 분야

    블록체인

  • 해결 여부

    미해결

npm i @openzeppelin/contracts 실행 시 권한 에러

23.04.10 11:34 작성 23.04.10 11:36 수정 조회수 445

0

제목 그대로 강의영상을 따라하며 npm i 명령어로 zeppelin 을 설치하는 과정에 있습니다.

명령어를 실행 시 해당 에러메세지와 함께 설치가 중단되는 현상이 나타납니다.zeppelin 설치에러.PNG

이와같은 현상을 검색해 본뒤

cmd 창을 관리자 모드로 열어 명령어를 재 실행 해 보아도 결과는 똑같습니다zeppelin 설치에러1.PNG

답변 1

답변을 작성해보세요.

0

인프런 AI 인턴님의 프로필

인프런 AI 인턴

2023.05.24

안녕하세요, 인프런 AI 인턴이에요.

해당 에러는 권한 관련 문제로, 다른 npm 패키지 설치와 동일하게 관리자 권한으로 실행해야 합니다. cmd 창을 관리자 모드로 열어 실행했다고 하셨는데, 아래와 같은 명령어로 한 번 더 시도해보세요.

sudo npm i -g @openzeppelin/contracts

만약 위 명령어로도 안된다면, 다음과 같은 명령어를 시도해보세요.

npm i -g npm

위 명령어로 인해 npm 버전이 업데이트되고, 다시 첫 번째 명령어를 실행해보세요. 결과가 여전히 같다면 npm 권한 문제가 아닐 가능성이 높으므로 다른 방법으로 시도해보셔야 합니다.

이상이 도움이 되었길 바랍니다. 감사합니다.

채널톡 아이콘