• 카테고리

    질문 & 답변
  • 세부 분야

    모바일 앱 개발

  • 해결 여부

    미해결

실행 오류 질문

22.08.04 15:16 작성 조회수 111

0

flutter 버전이랑 dart버전 다 맞췄는데 실행 했을때 이렇게 오류가 떠요. 어떻게 해야 하나요?
 

답변 3

·

답변을 작성해보세요.

0

FIrebaseuser를 user로 바꾸고도 저기가 계속 오류가 나는데 어떻게 해야 하나요.

 

Null Safety에 대해서 잘 모르시면(이 내용은 Flutter 입문 - 안드로이드, iOS 개발을 한 번에 - 강의 후반부에 설명합니다) Dart 버전을 2.7로 낮추고라이브러리 버전을 영상과 동일한 버전으로 진행해야 진행에 무리가 없습니다.

라이브러리 최신 버전은 사용법이 많이 바뀌었습니다.

https://firebase.google.com/docs/auth/flutter/federated-auth#google
위 사이트에서 제공하는 코드를 복사 붙여넣기 하시면 됩니다.
이 코드는 Null Safety 적용 코드이기 때문에 Dart 버전을 낮추지 않아야 제대로 동작합니다.

import 'package:google_sign_in/google_sign_in.dart';

Future<UserCredential> signInWithGoogle() async {
// Trigger the authentication flow
final GoogleSignInAccount? googleUser = await GoogleSignIn().signIn();

// Obtain the auth details from the request
final GoogleSignInAuthentication? googleAuth = await googleUser?.authentication;

// Create a new credential
final credential = GoogleAuthProvider.credential(
accessToken: googleAuth?.accessToken,
idToken: googleAuth?.idToken,
);

// Once signed in, return the UserCredential
return await FirebaseAuth.instance.signInWithCredential(credential);
}

0

onAuthAtateChanged 가 지정되지 않았다고 오류가 뜨는데 어떻게 해야하나요?

Dart 버전을 2.12보다 낮춰서 진행중이시라면 영상과 동일한 firebase_auth 버전을 사용하시면 될 거고요.

그 이후 버전으로 하신다면 변경된 사용법을 적용해야 합니다.

18번줄에 onAuthStateChanged => authStateChanges() 로 수정하시면 됩니다.

문서 링크입니다.
https://pub.dev/packages/firebase_auth/example

0

혹시 Flutter 입문 영상은 안 보셨을까요?

이 강의가 입문 강의에서 이어지는 강의인데요. 아직 에뮬레이터가 안 만들어져 있는 것 같습니다.

일단 공식 문서 링크 공유 드리겠습니다.

https://docs.flutter.dev/get-started/install/windows#set-up-the-android-emulator