• 카테고리

    질문 & 답변
  • 세부 분야

    게임 프로그래밍

  • 해결 여부

    미해결

안녕하세요 강의와는 관련 없을수도 있는 질문입니다.

20.05.12 23:53 작성 조회수 246

0

안녕하세요 강의 잘보고 있습니다 강의와는 관련없는 질문일수도 있으나 visual studio에서 유니티 전용 명령어를 사용할 시 (예를 들어 deltaTime) 자동완성 기능이 나오는데 저는 자동완성 기능도 없고 (public, float 이런건 있음) 저 함수들에게 파란색이나 노란색이 안나옵니다 어떻게 하면 강의처럼 똑같이 나오게 할 수 있나요ㅠㅠ 긴글 읽어주셔서 감사합니다

답변 2

·

답변을 작성해보세요.

1

손동욱님의 프로필

손동욱

2020.06.19

유니티 에디터에서 Edit - Preferences 에서 External Tools 에 External Script Editors 가 기본적으로 Open by file extension 으로 되어있을텐데 이걸 Browse로 비주얼 스튜디오가 설치되어있는 실행파일을 찾아서 비주얼 스튜디오로 켜주면 작동될 겁니다. Visual Stuido 2017 기준 위치는 C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE 이고 실행파일은 devenv.exe 입니다. 이렇게 해도 안될 경우 .NET Framework 를 최신버전으로 설치하시길 바랍니다.

0

eraser님의 프로필

eraser

2020.05.30

혹시 IDE로 vscode를 사용중이시라면 이 방법을 시도해 보시길 추천드립니다.

I found a fix for this in VSCode and it's only a few steps.

Your environment in VSCode may vary, but I have all the extensions you have in the OP.

But here's what I experience. I make a new project, after OmniSharp loads in VSCode. The packages don't highlight correctly, and I don't have intellisense. So I do the following:

  1. Delete the Assembly-CSharp.csproj from the project.
  2. Go to Unity -> Edit -> Preferences -> External Tools
  3. Look for the section near the top called "Generate .csproj files for:" and click "Regenerate Project Files" with everything unchecked.
  4. Then in VSCode I press "Ctrl + Shift + P" and run the action for "Developer: Reload Window"

Intellisense and all your other syntax highlighting should start working again.

I hope this works for y'all. I am on Unity 2019.3.13f1