• 카테고리

    질문 & 답변
  • 세부 분야

    백엔드

  • 해결 여부

    미해결

buildtool

24.04.24 18:12 작성 조회수 71

0

springboot 3.2부터 build and run 두 가지를 전부 gradle로 해야 한다 하셨는데, 예전 강의에서는 intellij 로 선택하라 하셨던게 기억나서 여쭤봅니다. 어떤게 바뀌어서 gradle을 고르라 하셨나요?

답변 1

답변을 작성해보세요.

0

인프런 AI 인턴님의 프로필

인프런 AI 인턴

2024.04.24

안녕하세요, 인프런 AI 인턴입니다. 정성훈님의 질문에 답변해 드리겠습니다.

스프링부트 3.2 이상 버전에서 “build and run”을 Gradle로 설정해야 하는 이유는 스프링부트의 최신 버전에서는 Gradle 또는 Maven과 같은 빌드 도구를 사용하여 애플리케이션을 빌드하고 실행하는 과정에서 성능 최적화와 특정 기능들의 지원이 강화되었기 때문입니다. IntelliJ IDEA로 설정했을 때와 비교하여, Gradle로 설정하게 되면 빌드 도구 자체에서 제공하는 추가적인 옵션과 효율성을 활용할 수 있습니다.

특히 스프링부트 3.2버전 이상에서는 Gradle을 사용한 빌드 및 실행 방식이 더욱 권장되는 추세로, 이러한 변경사항은 스프링 프레임워크 및 스프링부트가 지향하는 방향성과 관련된 개발 환경의 최적화를 반영하는 것입니다.

하지만 구체적으로 어떤 점이 변경되어 Gradle을 선택하도록 권장하게 되었는지에 대한 자세한 설명은 스프링부트의 릴리스 노트나 업데이트 사항에 대해 설명하는 공식 문서에서 확인할 수 있습니다.

현재 제공해드린 정보와 우려하신 부분에 대해 더 자세히 이해하고 싶으시면, 다음 링크를 참고해주세요:
- 스프링부트 3.2부터 빌드 설정
- 스프링 3.2 버전 이상에서 Run tests using 부분은 intelliJ IDEA 를 사용해도 되는지 궁금합니다.

위의 링크에는 스프링부트 3.2 이상 버전에서 Gradle 설정에 대한 질문과 답변이 포함되어 있습니다. 이를 통해 Gradle 설정의 필요성과 관련된 궁금증을 해소할 수 있을 것입니다.

저는 질문자님의 이해를 돕고자 지식공유자님의 기존 답변을 참고하여 유사한 답변 링크를 추천해드리고 있습니다.
현재 베타 기능으로 답변이 만족스럽지 않을 수 있는 점 양해 부탁드립니다. 🙏
추가적으로 궁금한 점이 있으시면, 이어서 질문해 주세요. 곧 지식공유자께서 답변해 주실 것입니다.

채널톡 아이콘