🤍 전 강의 25% 할인 중 🤍

2024년 상반기를 돌아보고 하반기에도 함께 성장해요!
인프런이 준비한 25% 할인 받으러 가기 >>

  • 카테고리

    질문 & 답변
  • 세부 분야

    백엔드

  • 해결 여부

    미해결

[공유]스프링 3버전 부터는 강의내용의 jstl 버전이 정상동작하지 않습니다

24.04.12 15:50 작성 24.04.12 15:51 수정 조회수 192

0

mvc -> member 목록 조회시 500 에러나시는분들..

jsp 내용은 그냥 지나쳐도 된다하시지만.. 에러나는게 신경쓰여서 찾아보니

gradle 의존성에 넣은 jstl 버전이 낮아서 500에러를 뱉더군요

 

의존성을 아래와 같이 변경하시고 gradle 재시작, 프로젝트 다시 빌드하시면 정상동작합니다.

 

//JSP
implementation 'org.apache.tomcat.embed:tomcat-embed-jasper'
implementation 'javax.servlet:jstl:3.0.1'
implementation 'jakarta.servlet:jakarta.servlet-api'
implementation 'jakarta.servlet.jsp.jstl:jakarta.servlet.jsp.jstl-api'
implementation 'org.glassfish.web:jakarta.servlet.jsp.jstl'

답변 1

답변을 작성해보세요.

0

y2gcoder님의 프로필

y2gcoder

2024.04.12

안녕하세요. 김지환님, 공식 서포터즈 y2gcoder입니다.

공유해주셔서 감사합니다!
혹시
image
본 챕터의 JSP로 회원 관리 웹 애플리케이션 만들기 강의자료의 스프링 부트 3.0 이상일 때와 같이 적용했을 때도 500에러를 뱉고 있다는 말씀이실까요?

감사합니다.

김지환님의 프로필

김지환

질문자

2024.04.12

아 자료에서는 3.0이상일때 따로 설명하고 있었네요 !

강의내용에서는 해당 부분이 없어서 따로 찾아봤습니다

채널톡 아이콘