• 카테고리

    질문 & 답변
  • 세부 분야

    블록체인

  • 해결 여부

    미해결

마이그레이션중 truffle과 solidity 버젼이 안 맞는 문제점

19.06.16 14:03 작성 조회수 181

0

truffle & contract 강좌중에

위의 그림을 보면 

MyContract.sol 파일에서 버젼 선언문에서

강사님의 예제파일은 pragma solidity ^0.4.24 로 선언되어 있습니다.

그런데 제가 만든 truffle 파일은 pragma solidity >=0.4.21 <0.6.0; 로 선언되어 있습니다.

그러다보니 마이그레이션시 이렇게 컴파일 에러가 나오기에

pragma solidity ^0.4.24 로 하지 않고, pragma solidity >=0.4.21 <0.6.0;  하게 되면 

pragma solidity >=0.4.21 <0.6.0;

contract MyContract {
struct Student {
string studentName;
string gender;
uint age;
}
 
mapping(uint256 => Student) studentInfo;
 
function setStudentInfo(uint _studentId, string _name, string _gender, uint _age) public {
Student storage student = studentInfo[_studentId];
 
student.studentName = _name;
student.gender = _gender;
student.age = _age;
}
 
function getStudentInfo(uint256 _studentId) public view returns (string, string, uint) {
return (studentInfo[_studentId].studentName, studentInfo[_studentId].gender, studentInfo[_studentId].age);
}
}

12번쨰 줄 string _name, string _gender,

20번쨰 줄 (string, string

이 부분이 에러가 나옵니다.

이걸 어떻게 해결 해야 하나요?

참고로 truffle 현재 가장 최신 버젼을 다운 받아서 사용하는겁니다.

 

답변 1

답변을 작성해보세요.

0

트러플 처음 설치하실 때 제가 공지사항으로 4.1.15 버전 받으라고 명시해놓았습니다. 기존 버전의 트러플 지우시고 (공지사항에 나와있음) 해당 버전 다운받고 하세요!