🤍 전 강의 25% 할인 중 🤍

2024년 상반기를 돌아보고 하반기에도 함께 성장해요!
인프런이 준비한 25% 할인 받으러 가기 >>

  • 카테고리

    질문 & 답변
  • 세부 분야

    데브옵스 · 인프라

  • 해결 여부

    미해결

The repository 'https://apt.kubernetes.io kubernetes-xenial Release' does not have a Release file.

24.03.27 13:53 작성 24.03.27 13:57 수정 조회수 1.59k

0

쿠버네티스 설치 작업하는 도중에 에러가 발생하고 있습니다.

쿠버네티스 설치 명령어 순서

  1. apt-get install -y apt-transport-https ca-certificates curl

  2. curl -s https://packages.cloud.google.com/apt/doc/apt-key.gpg | sudo apt-key add -

    cat <<EOF | sudo tee /etc/apt/sources.list.d/kubernetes.list

    deb https://apt.kubernetes.io/ kubernetes-xenial main

    EOF

  3. apt-get update

apt-get update 명령어를 사용하면 404 에러가 뜨고 있습니다.

root@k8s-master:/home/vagrant# apt-get install -y apt-transport-https ca-certificates curl

Reading package lists... Done

Building dependency tree

Reading state information... Done

ca-certificates is already the newest version (20230311ubuntu0.20.04.1).

The following NEW packages will be installed:

apt-transport-https

The following packages will be upgraded:

curl libcurl4

2 upgraded, 1 newly installed, 0 to remove and 99 not upgraded.

Need to get 398 kB of archives.

After this operation, 162 kB of additional disk space will be used.

Get:1 http://us.archive.ubuntu.com/ubuntu focal-updates/universe amd64 apt-transport-https all 2.0.10 [1,704 B]

Get:2 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 curl amd64 7.68.0-1ubuntu2.21 [161 kB]

Get:3 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 libcurl4 amd64 7.68.0-1ubuntu2.21 [235 kB]

Fetched 398 kB in 4s (110 kB/s)

Selecting previously unselected package apt-transport-https.

(Reading database ... 112280 files and directories currently installed.)

Preparing to unpack .../apt-transport-https_2.0.10_all.deb ...

Unpacking apt-transport-https (2.0.10) ...

Preparing to unpack .../curl_7.68.0-1ubuntu2.21_amd64.deb ...

Unpacking curl (7.68.0-1ubuntu2.21) over (7.68.0-1ubuntu2.19) ...

Preparing to unpack .../libcurl4_7.68.0-1ubuntu2.21_amd64.deb ...

Unpacking libcurl4:amd64 (7.68.0-1ubuntu2.21) over (7.68.0-1ubuntu2.19) ...

Setting up apt-transport-https (2.0.10) ...

Setting up libcurl4:amd64 (7.68.0-1ubuntu2.21) ...

Setting up curl (7.68.0-1ubuntu2.21) ...

Processing triggers for man-db (2.9.1-1) ...

Processing triggers for libc-bin (2.31-0ubuntu9.9) ...

root@k8s-master:/home/vagrant# curl -s https://packages.cloud.google.com/apt/doc/apt-key.gpg | sudo apt-key add -

OK

root@k8s-master:/home/vagrant# cat <<EOF | sudo tee /etc/apt/sources.list.d/kubernetes.list

> deb https://apt.kubernetes.io/ kubernetes-xenial main

> EOF

deb https://apt.kubernetes.io/ kubernetes-xenial main

root@k8s-master:/home/vagrant# apt-get update

Hit:1 http://us.archive.ubuntu.com/ubuntu focal InRelease

Get:2 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]

Hit:3 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease

Hit:4 https://download.docker.com/linux/ubuntu focal InRelease

Hit:5 http://security.ubuntu.com/ubuntu focal-security InRelease

Ign:6 https://packages.cloud.google.com/apt kubernetes-xenial InRelease

Err:7 https://packages.cloud.google.com/apt kubernetes-xenial Release

404 Not Found [IP: 142.251.214.142 443]

Reading package lists... Done

E: The repository 'https://apt.kubernetes.io kubernetes-xenial Release' does not have a Release file.

N: Updating from such a repository can't be done securely, and is therefore disabled by default.

N: See apt-secure(8) manpage for repository creation and user configuration details.

답변 3

·

답변을 작성해보세요.

3

itdeveloper님의 프로필

itdeveloper

2024.03.27

저는 아래 사이트를 참고하여 해결 하였습니다.

https://kubernetes.io/docs/setup/production-environment/tools/kubeadm/install-kubeadm/#installing-kubeadm-kubelet-and-kubectl

 

1. sudo apt-get install -y apt-transport-https ca-certificates curl gpg

2. sudo mkdir -p -m 755 /etc/apt/keyrings

3. curl -fsSL https://pkgs.k8s.io/core:/stable:/v1.29/deb/Release.key | sudo gpg --dearmor -o /etc/apt/keyrings/kubernetes-apt-keyring.gpg

4. echo 'deb [signed-by=/etc/apt/keyrings/kubernetes-apt-keyring.gpg] https://pkgs.k8s.io/core:/stable:/v1.29/deb/ /' | sudo tee /etc/apt/sources.list.d/kubernetes.list

5. apt-get update

6. apt-get install -y kubelet kubeadm kubectl

ed-kim-hoon님의 프로필

ed-kim-hoon

2024.05.15

도움이 되었네요 감사합니다.

1

R.K Zerotay님의 프로필

R.K Zerotay

2024.03.30

https://littlemobs.com/blog/kubernetes-package-repository-deprecation/

쿠버네티스 공식 레포지토리 경로가 변경된 듯합니다.

맨 윗분 답변처럼 현재 등록한 apt레포지토리를 삭제하고, 윗분의 코드를 그대로 치면 될 것 같습니다.

0

인프런 AI 인턴님의 프로필

인프런 AI 인턴

2024.03.27

안녕하세요, 인프런 AI 인턴입니다. SeJongDeveloper님의 질문에 대한 답변을 준비했습니다.

질문에서 언급하신 https://packages.cloud.google.com/apt kubernetes-xenial Release 저장소를 통해 업데이트를 시도할 때 404 Not Found 에러가 발생하는 문제는 Kubernetes 소스 리스트 설정 시 발생한 문제로 보입니다. 이러한 문제는 주로 Ubuntu 버전과 호환되는 Kubernetes 소스 리스트가 정확히 설정되지 않았을 때 발생합니다.

질문자님의 상황에서는 deb https://apt.kubernetes.io/ kubernetes-xenial main 을 사용하여 Kubernetes 소스 리스트를 추가하셨는데, 이 과정에서 문제가 발생했습니다. Ubuntu 20.04(focal)를 사용 중이라면, xenial 대신 focal을 사용해야 할 수도 있습니다.

아래와 같이 소스 리스트 파일을 수정해 보십시오:

# 기존 Kubernetes 소스 리스트 파일 삭제 또는 변경
sudo rm /etc/apt/sources.list.d/kubernetes.list

# Kubernetes 소스 리스트를 다시 추가
echo "deb https://apt.kubernetes.io/ kubernetes-focal main" | sudo tee /etc/apt/sources.list.d/kubernetes.list

# 패키지 리스트 업데이트
sudo apt-get update

이 과정을 완료한 후에는 다시 Kubernetes 관련 패키지 설치를 시도해 보십시오.

이 방법으로 문제가 해결되지 않는다면, 인터넷 연결 상태, 방화벽 설정, 또는 프록시 설정이 문제의 원인일 수 있으니, 이 부분도 확인해 보시기 바랍니다.

혹시 이 방법으로도 문제가 해결되지 않거나 다른 질문이 있으시면 추가로 질문해 주세요.

저는 질문자님의 이해를 돕고자 지식공유자님의 기존 답변을 참고하여 유사한 답변 링크를 추천해드리고 있습니다.
현재 베타 기능으로 답변이 만족스럽지 않을 수 있는 점 양해 부탁드립니다. 🙏
추가적으로 궁금한 점이 있으시면, 이어서 질문해 주세요. 곧 지식공유자께서 답변해 주실 것입니다.

채널톡 아이콘