주피터 노트북 저장 안되는 상황
풀스택을 위한 도커와 최신 서버 기술(리눅스, nginx, AWS, HTTPS, 배포까지) [풀스택 Part3]
혹시 저와 같은 상황이 발생하신 분이 계실까 하여 남깁니다. (혹시라도 저장을 하고 싶으신 분들을 위해) 주피터 노트북을 Docker로 실행하고 나서 저장을 하려는 시점에 permission Denied 가 발생하더라고요. 에러는 다음과 같습니다. 403 PUT /api/contents/work/mysql_in_docker.ipynb ({HOST_IP}): Permission denied: work/mysql_in_docker.ipynb 원인은 다음과 같습니다. -v 옵션으로 볼륜 연결을 하는데 제 호스트에 있는 directory에 권한이 없어서 발생했습니다. 저의 경우에는 해당 directory에 권한을 추가하여 처리 하였습니다. - sudo chmod o+w 2021_LEARN/ 수고하세요. 참고로 저장을 하지 않더라도 실행하는 데에는 전혀 문제가 없습니다ㅎ
- 주피터노트북
스탠바이랩
댓글 0
좋아요 0
조회수 1785





