• 카테고리

    질문 & 답변
  • 세부 분야

    백엔드

  • 해결 여부

    미해결

gradle 빌드 실패 오류

24.06.13 15:31 작성 조회수 255

0

안내에 따라 --warning-mode all 넣고 gradlew build

`--scan` 결과

현재 gradle-wrapper.properties에 나오는 gradle 버전은 8.5입니다.

The automatic loading of test framework implementation dependencies has been deprecated. This is scheduled to be removed in Gradle 9.0. Declare the desired test framework directly on the test suite or explicitly declare the test framework implementation dependencies on the test's runtime classpath.

이 문제를 해결해야 할 것 같은데, gradle 버전을 업그레이드 해야 할까요?

답변 2

·

답변을 작성해보세요.

0

OMG님의 프로필

OMG

2024.06.13

안녕하세요. ysj님, 공식 서포터즈 OMG입니다.

gradle-wrapper.properties 의 버전을 9.0으로 변경하시고 다시 빌드 해서 확인해주세요 😀

해결이 안될 경우 댓글 남겨주세요.

감사합니다.

0

인프런 AI 인턴님의 프로필

인프런 AI 인턴

2024.06.13

안녕하세요, 인프런 AI 인턴입니다.

ysj님의 질문은 Gradle 빌드 실패와 관련된 문제로, 특히 테스트 단계에서 발생하는 오류와 Gradle 버전 8.5 사용 중 나타나는 경고 메시지에 대한 것입니다. 여기서 중점적으로 다루어야 할 부분은 테스트 프레임워크 구현 의존성의 자동 로딩이 Gradle 9.0에서 제거될 예정이며, 이로 인해 발생한 빌드 실패입니다.

이와 비슷한 상황에 대해 이미 토의된 답변이 있어 이를 참조하시는 것이 도움이 될 수 있습니다. 다음은 유사한 문제를 다루는 질문 링크입니다:

  • Gradle 빌드 실패 관련 질문: 이 글에서는 Gradle 빌드 실패 문제와 Gradle 버전 충돌이나 설정 문제를 다루고 있습니다. 특히, 구체적으로 :JpashopApplication.main() 작업 실패와 관련된 오류 메시지에 포커스를 맞추고 있지만, Gradle 설정과 오류 해결에 대한 일반적인 조언이 포함되어 있어 도움이 될 수 있습니다.

  • Gradle 오류.. ? : 이 경우는 Gradle 빌드 중 나타난 오류와 관련된 질문으로, Gradle 버전 호환성 문제와 특정 작업 수행 실패에 초점을 맞추고 있습니다. 빌드 설정 조정 및 버전 관리에 대한 조언이 제공됩니다.

이러한 경우, 직접적인 해결책으로 버전을 업그레이드하는 것 외에도, 테스트 프레임워크의 명시적 선언 등 다양한 접근 방법을 고려할 수 있습니다. 현재 사용 중인 Gradle 버전이 경고를 발생시키는 기능에 의존하고 있으므로, 버전 업그레이드 전에 해당 기능이 제거될 예정인지, 그리고 업그레이드 시 호환성 문제가 없는지 확인하는 것이 중요합니다.

Gradle 공식 문서나 Gradle 커뮤니티 포럼에서 특정 버전과의 호환성이나 변경된 기능에 대한 정보를 확인할 수 있습니다. 또한, 테스트 의존성을 명시적으로 선언하는 방법에 대한 구체적인 지침은 Gradle 공식 문서에서 찾을 수 있습니다.

저는 질문자님의 이해를 돕고자 지식공유자님의 기존 답변을 참고하여 유사한 답변 링크를 추천해드리고 있습니다.
현재 베타 기능으로 답변이 만족스럽지 않을 수 있는 점 양해 부탁드립니다. 🙏
추가적으로 궁금한 점이 있으시면, 이어서 질문해 주세요. 곧 지식공유자께서 답변해 주실 것입니다.

채널톡 아이콘