• 카테고리

    질문 & 답변
  • 세부 분야

    모바일 앱 개발

  • 해결 여부

    해결됨

NewPostViewModel.swift 생성후 오류 질문

24.06.13 03:10 작성 조회수 101

1

NewPostViewModel.swift 파일에서 @Observable에

Unknown attribute 'Observable' 이런 오류가 발생합니다...

찾아보니 ios버전이 17이하버전에서는 Observable을 사용할 수 없다고하는데, 제가 지금 16.4버전을 사용중에 있습니다. 버전을 업그레이드하려는데, 이 부분도 해결이 되지 않아서 그러는데, 어떻게 해야할까요?

답변 2

·

답변을 작성해보세요.

0

Observable 매크로를 사용하려면 iOS 17이 필요한데요

iOS 17은 xcode 15버전대부터 사용가능합니다.

xcode 15.4까지 나와있는데요. 15.4와 15.3은 macOS를 ventrua다음버전인 sonoma까지 올려야지만 설치가 되지만

xcode 15.0부터 xcode 15.2까지는 ventura 13.5까지만 업데이트 하시면 설치하실 수 있습니다.

 

즉 현재 macOS를 ventura 13.5이후 버전으로 업데이트하시고(sonoma로 업그레이드 하실 필요는 없습니다.)

xcode를 15.0~15.2중에 아무거나로 업데이트 하시면 됩니다.

(나중버전이 버그가 적어서 15.2를 추천드릴게요)

 

ventrua를 업데이트하면 아마 appstore에서 xcode update버튼이 뜰텐데요.

그걸로 업데이트하시면 됩니다.

 

혹시 update버튼이 안뜬다면

https://developer.apple.com/download/all/?q=xcode

이사이트에서 다운받으실 수 있습니다.

(개발자계정이 필요해서 회원가입이 필요할 수 있습니다.)

 

혹시 막히는 사항 있으시면 또 질문 주세요~

감사합니다!

0

이기혁님 안녕하세요

혹시 Xcode버전하고 macOS버전을 알 수 있을까요?


xcode 버전은 xcode 실행후 다음화면에서 확인할 수 있고

imageimage

 

macOS버전은 다음화면에서 확인할 수 있습니다.

 

 

image

image

 

 

이기혁님의 프로필

이기혁

질문자

2024.06.13

버전은 이렇습니다.

채널톡 아이콘