API 조회에서 에러가 납니다.

미해결질문
allen lim 프로필

const Eos = require('eosjs');

 

const config = {

    httpEndpoint: 'http://178.62.36.41:8888'

};

 

Eos(config).getInfo((error, info) => {

    if(error){

        console.error(error);

    }

 

    console.log(info);

});

 

 

결과가 아래와 같이 오류로 나옵니다.

다른 

HTTP API LIST를 사용해도 동일합니다.

 

TypeError: Eos is not a function

    at Object.<anonymous> (/Users/hyungsoolim/eos/getInfo.js:7:1)

    at Module._compile (internal/modules/cjs/loader.js:721:30)

    at Object.Module._extensions..js (internal/modules/cjs/loader.js:732:10)

    at Module.load (internal/modules/cjs/loader.js:620:32)

    at tryModuleLoad (internal/modules/cjs/loader.js:560:12)

    at Function.Module._load (internal/modules/cjs/loader.js:552:3)

    at Function.Module.runMain (internal/modules/cjs/loader.js:774:12)

    at executeUserCode (internal/bootstrap/node.js:342:17)

    at startExecution (internal/bootstrap/node.js:276:5)

    at startup (internal/bootstrap/node.js:227:5)

Dong Jun Kwon 프로필
Dong Jun Kwon 2019.06.03

eosjs를 설치 하셧나요? 설치 하셨으면 버젼이 20.으로 되면서 나는 부분이에요. 20.0으로 버젼 업이 퇴근에 되서요. 해당 강의는 v16.x 버젼으로 진행하셔야되요.

지식공유자 되기
많은 사람들에게 배움의 기회를 주고,
경제적 보상을 받아보세요.
지식공유참여
기업 교육을 위한 인프런
“인프런 비즈니스” 를 통해 모든 팀원이 인프런의 강의들을
자유롭게 학습하는 환경을 제공하세요.
인프런 비즈니스