webpack@4 부터 cli가 분리되어 따로 설치하라고 하는 관련

미해결질문
김종현 프로필

말 그대로 webpack@4부터 webpack-cli 를 따로 설치하라고 뜹니다.

문제는 npm install webpack-cli를 통해 따로 설치하여도 여전히 webpack에서 cli를 찾지 못하는 문제가 발생하더군요.

도저히 빡쳐서 webpack@3으로 버젼을 낮추어서 설치를 했는데, 이렇게 하니까 또 babel이랑 안 맞다고 메시지가 ㅋㅋㅋㅋㅋㅋ

걍 zip 받아서 따라해버리긴 했는데, webpack@4용 cli 문제를 좀 보충해 주시면 안될까 싶어요... ㅠㅠ

Coding bear 프로필
Coding bear 2018.03.16

babel-preset-es2015는 ES2015 변환에 쓰이지만 babel-preset-env는 ES2015는 물론 ESS2017까지 변환할 수 있도록 합니다. 그래서 권장하는 것 같습니다.