인프런 업데이트 소식 🔨👷🏼‍♂️

npm webpack 설치시 Warning 사항인데… 이거 때문에 실행 안되는 것 같아요

미해결질문
이춘길 프로필
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_moduleswebpacknode_modulesfsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_moduleswebpack-dev-servernode_modulesfsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

webpack cli를 설치하라는 Warn도 뜨고 여러가지 에러가 떠서

지금 다시 지웠다가 실행중인데, 위에 사양 관련 Warning이 관련이 있을까요?

유태선 프로필
유태선 2018.03.16

webpack 설치하다가 그런신거 같은데요.(아니면 말고요)
npm i -g webpack webpack-cli && npm i -D webpack webpack-cli
웹팩3까지는 webpack만 설치해도 되었는데 웹팩4부터는 webpack-cli를 같이 설치해야 커맨드라인에 webpack이란 명령어를 사용할 수 있습니다.
참조링크
https://www.zerocho.com/category/Webpack/post/58aa916d745ca90018e5301d